0

I am trying to prepare a raster file which i could use with SAGA processing tools for hydrologic analysis in QGIS. I am using Win 7, 32 bit, QGIS 2.14.20 and SAGA 2.3.2 I downloaded the srtm file in hgt format from the net. After i converted the file to a Geotiff while reducing the size with the QGIS clipper tool. I changed as well the CRS to UTM.

I have seen on this answer to a rather similiar question: QGIS: Saga Channel network: how to prepare SRTM data that i should try the Fill sinks under SAGA. But even this function doesn´t work with my raster. I get the output, just as for the other tools, that: the layer(s) couldn´t be created. I am quite sure that my QGIS/ SAGA setup is fine, because i tried all operations with a Raster DEM provided from QGIS and the SAGA tools worked all right and prepared what i am looking for. Therefore i suppose there must be a mistake in my raster file. I tried to change pixel value <=0 to no data value with the raster calulator but without success! I would be very glad if someone can provide a direction for a solution.

As decribed above i start with the SRTM hgt file. Step 1: Save the hgt as a Geotiff and change of CRS to UTM with the right click menu under "save as"

Step 2: I created a polygon vector mask layer and used the QGIS clipper under Raster - Extraction - Clipper:

The raster file i get has the following metadata: ]

Step 4: I tried using this layer with different hydrologic processing tools, SAGA and GRASS under QGIS. Here an example for GRASS using the _r.stream.extract_ tool:

This is the error i will get for unfortunately all the tools i tried to use:

  • 1
    Give a try to GRASS GIS. See grass.osgeo.org/wiki/Hydrological_Sciences for options and why sink filling is not needed in GRASS GIS – Marco Dec 6 '17 at 9:46
  • Thanks. I am sure that GRASS is a good option. I tried the GRASS 7 in the QGIS processing toolbox. I tried r.stream.extract and r.watershed but i get the same error: The following layers were not correctly created Since i tried again with the raster data provided from QGIS and it worked i am quite sure it must be any problem with my raster file. – Schnake Dec 6 '17 at 10:26
  • Please, edit your question and provide more info about your data, the commands you tried and the errors. I have used r.watershed and r.water.outlet many times and it should be a straightforward task – Marco Dec 6 '17 at 10:54
  • From the look of the colorful part (assuming it is the clipped area), which has jagged edges, I am afraid you might have reprojected it to UTM after clipper operation. Can you expound the order of your workflow? – Kazuhito Dec 6 '17 at 18:04
  • 1
    I opened an new QGIS project and tried again with r.watershed and the file as created above, and following the error indication in the LOG that: ERROR: The basin threshold must be a positive number. I changed Minimum size of exterior water shed basin and Maximum length of surface flow, for USLE from 0 to 1. And it finally worked with GRASS! – Schnake Dec 7 '17 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.