0

Software: ArcGIS Pro 2

I am having an issue with the Reclassify tool. I am attempting to reclassify raster data into three classes so that I can do a habitat suitability analysis. When I use the Reclassify tool on some raster data I have (not all raster data I have) the resulting reclassified raster has several NoData strips in seemingly random areas across my study area. These strips are not NoData areas within my Input raster. Please see examples below:

Input Raster:

enter image description here

Reclassified Raster (white = NoData):

enter image description here

I haven't been able to figure out exactly what could cause this, mainly because I'm not sure where to start. Has anyone experienced this issue?

  • I am not sure if this is the issue, but Esri grid has limited character number, you need to reduce the length of the output raster name or use `.tif' or '.img' extension if you want to keep long names. – ahmadhanb Dec 6 '17 at 4:54
  • Thanks for the response. I shortened all the output names and it worked! A little strange since one of the output rasters that did work initially had a 12+ long name. Post it and I will mark it as an answer. – Skiri Dec 6 '17 at 5:23
  • Glad it solved the problem :) – ahmadhanb Dec 6 '17 at 5:30
2

Sometimes reclassification and other spatial analyses can act strangely due to strange reasons such as raster names. Esri grid has limited character numbers, so you have two options:

  1. Reduce the length of the output raster name if you want to stick with Esri grid
  2. Or use .tif or .img extensions if you want to keep long names.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.