1

I try to load layer of population in U.S.A on base map of google earth satellite. this this part of the attribute table:

enter image description here

My problem is that the point located in worng place:

enter image description here

I tried to change the CRS in order to locate the point in the right place- but with no success. Now the CRS is EPSG:3857

I red Can someone clear up a Google Maps/ArcMap lat/long issue? but didn't understand how can i solved my problem.

But when i load the layer (csv file) and change the layer CRS into EPSG 4326 the point located in the right place (i think...)

enter image description here

When i open the project properties there is WGS84 grid:

enter image description here

I really confused from this issue- how can i change the CRS so it will be the same as the project + layer+base map of google

1

Your CSV data is in EPSG:4326 (WGS84) and so you must set the layer projection to be that. With on the fly reprojection turned on QGis will take care of making the data line up with the Google base map (EPSG:3857) so there is no need for you to do anything else.

The ellipsoid in the project properties page is for calculating distances and has nothing to do with this issue so you can safely ignore it.

  • so i get this result: the base map is in EPSG 3857 and the layer is in EPSG 4326- is that normal Ian Turton? – newGIS Dec 7 '17 at 9:43
  • that is common, the whole point of GIS is to allow you to work with data in different projections – Ian Turton Dec 7 '17 at 9:44
1

I assume you are OpenLayers Plugin which has many issues regarding the projection.

I tested The sample data that you provided, I did not anything special. I saved them as CSV from Excel, import them in QGIS using Add Delimited Text Layer, and saved the output as Shapefile with WGS 84 CRS.

I used QuickMapService Plugin and everything was OK. The points are located correctly in USA, as you can see below:

enter image description here

  • i did what you suggested- it still located in Africa instead of USA – newGIS Dec 7 '17 at 8:39
  • Try to load your data in a new QGIS project file – ahmadhanb Dec 7 '17 at 8:44
  • ok i will try it – newGIS Dec 7 '17 at 8:56
  • ahmadhanb, i didn't success applied your idea – newGIS Dec 7 '17 at 11:20
  • @newGIS No Problem at all. I am glad Ian Turton solved your problem :) – ahmadhanb Dec 7 '17 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.