18

I want QGIS interface in English in order to share the information with the GIS community. Using other language than English when chating with the GIS community is very difficulte. When I installed QGIS, it automatically set the language to French. Very frustrating to not have the opportunity to select my own language.

I am using Windows XP in French but want QGIS in English.

  • It helps to me also from croatian language to english :-) – user29724 Apr 30 '14 at 8:21
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – Martin Apr 30 '14 at 8:54
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – PolyGeo Apr 30 '14 at 9:12
  • Please don't add "thank you" as an answer. Once you have sufficient reputation, you will be able to vote up questions and answers that you found helpful. – Devdatta Tengshe Apr 30 '14 at 9:41
  • The question about changing the language from French to English in 2012 has been viewed 11210 times. It is now the end of 2015 and still a Basic English version is unavailable to download! I know this tool is available due to the goodwill of many but heck French is long winded and well Chinese might be of more use to a larger population... I'm trying to force the language change option but not sure that when I reopen QGIS that it will have stuck. Really disappointed. – MsMesem Dec 1 '15 at 20:12
31

Sure, just go to the options dialog:

Préférences->Options->Langue (Settings->Options->Locale)

Check Forcer la nationalité du système (Override system locale) and set you language in there.

  • 2
    In QGIS 3.0 the "Override system locale" can be found under "Settings -> Options -> General" right at the top – knutella Mar 23 '18 at 15:13
9

No need to uninstall QGIS.

All QGIS settings are stored in the registry at HKEY_CURRENT_USER\Software\QuantumGIS\QGIS\

If you look for the key HKEY_CURRENT_USER\Software\QuantumGIS\QGIS\locale you will see it has a overrideFlag and userLocale setting. Make sure that overrideFlag is set to false.

You can also start QGIS with a command line arg to tell it which language to use:

qgis.bat --lang en_US

Once you are in QGIS head to Settings -> Options -> Locale and make sure override system locale is unticked and that the additional info section gives you the correct language, mine is en_AU for example.

4

I found it... Options/Local then Override system local... :)

2

Settings (or extra) --> options --> Locale --> (click to override) then chose language --> restart the programme to apply the new settings

protected by Community Apr 6 '18 at 4:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.