I have a mosaic dataset and it contains GRIB data sets. I want to publish this dataset as a time aware map layer. For this I use ArcMap 10.5.1 and ArcGIS for Server 10.5.1 on Windows. Unfortunately I've run into a problem with the time info settings for which I could not find a solution elsewhere. The issue that I have is that the layer is published with the setting "Has Live Data" set to "false" when I need it to be "true" since data are constantly added to that mosaic dataset. In ArcMap on Layer Properties -> Time tab I can enable the the checkbox "Data changes frequently so calculate time extent automatically", however it looks like this setting is ignored when the layer gets published on ArcGIS server.

By the way, when I publish time aware vector data layers the map service shows correct time info settings.

Did anybody else had the same problem? Were you able to solve it? Any workarounds?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.