2

I've configured a web app in ArcGIS Online and I'm unable to get the editor and smart editor widgets working. Both widgets state the web map has no editable layers. I've enabled editing for the layer I'm working with and I've confirmed I'm working with the correct web map. I think the issue may be a bug in the software because I'm able to edit the layer in map viewer and I can edit the layer using the predefined edit template. Could the issue be sharing? I'm currently only sharing with my organization. I guess it would help if somebody could confirm if the steps below are missing anything. Again, it's odd because the web map does have editable layers.

Step 1: Upload layer to AGO

Step 2: Configure sharing with my organization

Step 3: Enable Editing

Step 4: Create Web Map, Add layer, (editing works at this point)

Step 5: Share web map

Step 6: Create app using the web app builder

Step 7: Add the editor widget (no editable layers at this point)

  • Perhaps share layer from arcgis as feature service. – FelixIP Dec 12 '17 at 23:09
  • if possible can you share the layer? – Russ Roberts Dec 13 '17 at 14:23
1

I think ArcGIS Online takes a while to update. I updated the layer to allow editing and it worked after about a half hour. I've also noticed a delay when adding fields. I'll add a field and open up a web map with that layer and it takes about 10-15 minutes before I see the field in the layer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.