2

My QGIS 3 (2.99, Ubuntu 16.04) stopped upgrading today. When doing sudo apt-get upgrade, I get an error about Unmet dependencies.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:2.99.0+git20171211+61db97f+24xenial-ubuntugis) but 1:2.99.0+git20171209+fb28adf+24xenial-ubuntugis is installed
E: Unmet dependencies. Try using -f.

Doing

$ sudo apt-get -f install

as suggested, I get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libqt5script5
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  qgis-provider-grass
The following packages will be upgraded:
  qgis-provider-grass
1 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
22 not fully installed or removed.
Need to get 0 B/2,068 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 


(Reading database ... 286420 files and directories currently installed.)
Preparing to unpack .../qgis-provider-grass_1%3a2.99.0+git20171211+61db97f+24xenial-ubuntugis_amd64.deb ...
Unpacking qgis-provider-grass (1:2.99.0+git20171211+61db97f+24xenial-ubuntugis) over (1:2.99.0+git20171209+fb28adf+24xenial-ubuntugis) ...
dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive /var/cache/apt/archives/qgis-provider-grass_1%3a2.99.0+git20171211+61db97f+24xenial-ubuntugis_amd64.deb (--unpack):
 cannot copy extracted data for './usr/lib/qgis/plugins/libgrassprovider7.so' to '/usr/lib/qgis/plugins/libgrassprovider7.so.dpkg-new': unexpected end of file or stream
Errors were encountered while processing:
 /var/cache/apt/archives/qgis-provider-grass_1%3a2.99.0+git20171211+61db97f+24xenial-ubuntugis_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I use the following repositories in my /etc/apt/sources.list:

deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu xenial main
deb http://qgis.org/ubuntugis-nightly xenial main

So far, apt-get is broken and keeps asking me to do apt-get -f install no matter what (autoremove, autoclean, clean etc.).

Does anyone have similar experience or know of a fix?

Post is related to a rapidly changing event.

  • Looks like a packaging or download error of qgis-provider-grass. Try sudo dpkg --configure -a or remove or purge the package. – AndreJ Dec 13 '17 at 6:59
1

Post is related to a rapidly changing event.

I guess the solution is to wait a day or two. I tried sudo apt-get upgrade again, and it succeeded.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.