I want to load a csv file into QGIS, and the data in QGIS as point layer. I have tried to use this function:

Layer ► Add layer ► Add Delimited Text Layer.

When Im loading the file name, the data comes like this in the box:

Creating a layer from a delimited text file

All the data is just in one column. Latude and longitude should be x,y values. I had GHI, Latitude and Longitude in different columns in excel, like this:

enter image description here

To make the csv file I saved as "CSV (comma delimited).

So how can I load the csv file correctly? I havent done a operation like this before.

  • 5
    Set the option "custom delimiters" and choose your seperator (semi-colon).
    – Matte
    Dec 13, 2017 at 15:03
  • 2
    Your data seems to be "semicolon separated values", not "comma separated values". Select "custom delimiters".
    – user30184
    Dec 13, 2017 at 15:04

1 Answer 1


Since your data is delimited by semicolons, you must select "Custom Delimiter" then "Semicolon".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.