2

I have been following a course on Udemy using GeoServer (my version is 2.12.0). I plug in the same SQL code used in the course but when I click "Guess SQL Parameters", this message shows up:

org.apache.wicket.WicketRuntimeException: Exception in rendering component: [WebMarkupContainer [Component id = selectItemContainer]]

enter image description here enter image description here

Perhaps it has something to do with Java? This morning I went to start GeoServer and it wouldn't start, so I looked at the startup.bat file and it was looking for a Java file that disappeared from my computer somehow (it wanted Java/jre1.8.0_73; I had jre1.8.0_71 and had just installed jre1.8.0_151, so I changed it to the latter and it started up just fine, but the error message seems to suggest that it's Java related.

  • Okay, I'll install the latest version of GeoServer then! Thanks! – Ryan Norton Dec 13 '17 at 21:00
  • @chrki: you should make this an answer, not a comment. – pLumo Dec 14 '17 at 8:18
  • 1
    @RoVo I wasn't sure how to proceed, see gis.meta.stackexchange.com/questions/4185/… -- I posted it as an answer now – chrki Dec 14 '17 at 8:48
5

Geoserver 2.11.3 and 2.12.0 (you are using this one) had a bug with "Guess SQL parameters" that caused it to fail like you described.

This has been fixed in 2.12.1 (released in stable branch) and 2.11.4 (currently only in nightly). You can read the bug report of the Geoserver bug tracker here: https://osgeo-org.atlassian.net/browse/GEOS-8363

  • I wonder if my IT guy installed the new version correctly- I still get that message! – Ryan Norton Dec 15 '17 at 13:52
  • I still get that message after installing 2.12.1. I'll try 2.11.4 when it comes out next week. – Ryan Norton Dec 15 '17 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.