2

I have been trying to use brew to install QGIS 3.0 dev on my Mac running 10.13 (High Sierra) without any success. I have reported the details on GitHub as Cmake errors installing on mac os 10.13.1 but have not had any response. If anyone has managed this it would be great know if there were anything special that was needed.

I am using this command at present:

brew install --no-sandbox qgis/qgisdev/qgis3-dev

which is referenced at Install QGIS3 (QGIS-dev) on MacOSX as working recently.

It is frustrating that brew removes the build directory including the output from the qgis compile so one can't examine the entrails :(

Alternately is there any other way of building QGIS on a Mac?

2

I've installed it on 2 Macs running the latest 10.13.2 at this point. First, download the formula using brew install --no-sandbox qgis/qgisdev/qgis3-dev as you mentioned.

It will then complain about not finding homebrew/science/matplotlib, so I ran brew edit qgis3-dev and removed the line from the formula requiring it.

After that, running brew install --no-sandbox qgis/qgisdev/qgis3-dev again compiled everything and it worked!

I'm not sure if matprotlib is required as it may have already been installed from the older version of QGIS on my systems. There are instructions online about installing it using pip if you need it but I got it to compile and run without doing that. Hope this helps!

  • Good to know that is does work for some. I have now found the output from cmake and thus the actual error: CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: QTKEYCHAIN_INCLUDE_DIR – Russell Fulton Feb 3 '18 at 20:56
  • When you build it pulls the latest potentially unstable master and there are dozens of commits per day right now. I just successfully re-built it today at commit 325af48680 without error, latest High Sierra, latest XCode. I'd give it another shot, hopefully your last attempt was just a bad pull. If not that, then maybe you are missing some dependencies for some reason. I have qt and qtkeychain installed in addition to the full Qt5 dev framework I had previously installed from qt.io. Hope you get it working! – te465 Feb 5 '18 at 15:35
  • Do you know how long takes compiling? I've cleaned all the warnings but when I run install --no-sandbox... Stands in "make" too long, and I don't know if it's normal. – Pablo Pardo Mar 4 '18 at 17:57
  • It takes about 5 minutes on my machine (4GHz 5K iMac)... with all cores maxxed out and a bit longer than that on my MBP. – te465 Mar 5 '18 at 19:19
  • 1
    Just wanted to point out that it doesn't find homebrew/science/matplotlib because homebrew/science has been discontinued. Just changing homebrew/science/matplotlib/to matplotlibshould work (no need to actually remove matplotlib) – arredond Mar 13 '18 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.