2

A week ago my QGIS wouldn't start anymore. When I double click the desktop shortcut nothing happens. When I run in from the .exe in the bin I get the error that some DLL files are missing. These files are however present in the map 'apps'.

On this forum several suggestions are given. I tried booting from the qgis.bat file, but that does not work. I also tried uninstalling QGIS and deleting all temporary files to ensure a clean re-install. Also does not work. I tried installing older versions, but they all give the same error.

One thread also suggests modifying the .bat file by adding : PATH %systemroot%\system32; %systemroot%; %systemroot%\system32\wbem after @echo off. Also didn't work.

Lastly I installed the latest Microsoft Visual C ++ which also had no effect.

I use a Windows 10 pro edition 64 bit on my desktop. I'm not sure, but I think QGIS stopped working after a major update. When I went back to before the update, QGIS still wouldn't work however.

closed as off-topic by PolyGeo Mar 24 '18 at 5:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • If you are currently using the stand-alone installer, you might want to try the OSGeo4W installer instead. – underdark Dec 16 '17 at 17:59
  • Thanks for the suggestion. I tried installing with the OSgeo4W installer, but the same issue still exists. After the installation i got the error that the 'QGIS-common' and the 'QGIS-common.bat exit code 255' where not installed. I tried starting it using all the above described methods, but no succes. – Tom van Heusden Dec 17 '17 at 16:17
  • Have you tried to install the previous version? Like 2.18.14 or 2.18.12? I encountered with this problem several times and always try to uninstall the latest version of QGIS and install with previous version (i.e. if i got error in QGIS 2.18.15, I try QGIS 2.18.14) – Adityo Jan 9 '18 at 4:06
  • Yes i tried. Also didn't work. I currently gave up and only use qgis on my laptop where it works perfect. Only thing i didn't try yet for my desktop is reinstalling windows. Seems to me like the last option. – Tom van Heusden Jan 10 '18 at 8:28
  • I have the same problem too. Have you find any solution? – Dimitris Kasabalis Feb 6 '18 at 11:14

Browse other questions tagged or ask your own question.