1

I have been having problems applying the different CRS systems to my layers. I have generate a variable distance buffer that I want to be circles around point on a Google Street Map of a city.

When I set the the CRS as 'EPSG:4326, WS 84' the circles appear as ovals: First attempt

When I set the CRS as 'EPSG:3857 Pseudo Mercator', while the shapes are the correct shape, they will not appear with the base map, and the base map is nowhere to be found.

Second attemp

This is confusing, given the the Google maps layer's CRS is 'EPSG:3857 Pseudo Mercator'!

I have read all the other questions/answers that I could find on this topic. I have tried saving it as a new layer (with different CRS) and changing the CRS of the layer before creating the buffer circles.

Edit: solution below

  • 1
    Well, what actual CRS are your buffers in? Don't change the CRS of a layer in its properties, that overrides it in a way you probably did not mean to use. – bugmenot123 Dec 18 '17 at 8:50
  • Ensure the Project CRS is set at EPSG:3857 and your point layer has been saved with the same CRS (otherwise right-click your layer, use the Save As... option and select the same CRS). Then try the buffer tool again. – Joseph Dec 18 '17 at 10:16
  • 1
    @Joseph I tried this out, and it worked. Thank you! – Alyse Dec 18 '17 at 22:55
1

Your shapes will appear distorted in WGS84/4326 because the coordinate system does not preserve shape or area.

Web Mercator (3857) will make the shapes look better, but beware if your source data is in 3857 you will have distorted area values, so watch out if you're doing anything specific to that measurement with those circles.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.