1

For the purposes of a demonstration, I'm trying to set up a base deployment of ArcGIS Enterprise on a standalone VM (VMWare Workstation) running Windows Server 2016 Standard. It seems that, as it's been billed by Esri, using the ArcGIS Enterprise Builder it should be straightforward. However, as with most things Esri, it's one step forward and two steps back. I've fallen down a rabbit hole of setting up a domain controller and certificate authority on the VM, and now I'm mired in issuing and configuring domain certificates. As I rained blows upon it, I realized that there had to be another way.

Can anyone provide a concise set of steps for getting a base deployment up and running on a standalone VM? Happy to contribute to writing a guide if we can get it working.

  • Perhaps best to ask on the ESRI GeoNet forum? Also you might want to reach out to the technical support that comes with your ESRI license. – DPSSpatial Dec 18 '17 at 19:07
  • Where did what you observed first depart from what you expected by reading its documentation? – PolyGeo Dec 18 '17 at 20:02
  • The Portal class does this exact thing, though it has a VMPlayer configured to be the domain controller, and the needed certs are already provided. It sounds like you're hung up on the IT portion of the task. – Vince Dec 19 '17 at 4:59
  • @Vince What is this Portal class you speak of? – Jonathan Bailey Dec 19 '17 at 11:57
2

The steps to install ArcGIS Enterprise with the Application Builder is well documented already, and have successfully used this to install both 10.5 and 10.6 on several machines both virtual and physical.

However, I do understand that moving from a standalone GIS Server to a full stack is a bit of a jump, especially for those of us in GIS that may not have much experience in IT (e.g. me)

From what you have mentioned, I believe the issue you are having is that although the Virtual Machine is Windows Server 2016, it is not setup on a domain and therefore does not have a fully qualified domain name (requirement).

A few options, and this is really more on the IT side of the prerequisites for ArcGIS Enterprise.

You need to have a fully qualified domain name in order to successfully run through ArcGIS Enterprise Application Builder.

For demonstration purposes, the self-signed certificates that are included are sufficient, but if you like you can also generate a wildcard domain certs from the domain controller and bind this to the IIS root site that the web adapters are installed into. This happens after you run through the motions with Enterprise builder, and is a separate question.

Another approach for spinning up demo environments is to make use of the Cloud Builder for Azure/Amazon. This is my personal preference for quick deployments of ArcGIS Enterprise. You might even find your organisation has Azure credits, and I believe they also give out a free plan which might have enough credits for your demo purposes.

Suggest making friends with your IT team if required.

1

The Esri training class is taught with four VMs in a single virtual host, with a doman controller, a web server, an ArcGIS Server host, and a Portal host. It is probably overly ambitious to try to make this operate in a single VM.

In fact, it probably isn't possible to run all the components on the PDC (it was years ago now, but I remember the instructor mentioning issues when the PDC was not a separate VM). It is best practice to use different hosts for the Web Adaptors, Server, and Portal components, and Data Store and RDBMS should also be in that rule for production use, as well. Larger instances will of course have multiple Server hosts and a load-balancer in front of multiple web servers.

If you create a separate VM for the PDC and use a wildcarded SSL certificate for the virtual hosts (with aliases fror the component host names), your configuration should just work with as-is documentation.

  • Well, except that this is using ArcGIS Enterprise Builder, the purpose of which is to install the ArcGIS Enterprise components on a single machine. – Jonathan Bailey Dec 20 '17 at 19:31
1

On a standalone Windows server, I also change the server settings so that it automatically adds a DNS suffix (I tend to use *.local.net)

Here's an article that can help: https://www.server-world.info/en/note?os=Windows_Server_2016&p=initial_conf&f=3

The update the hosts file and you should be good to go. I have a few all in one ArcGIS Enterprise deployments on locally hosted VMs; disconnected from any Domains all running as workgroups.

-3

ArcGIS Server installation on Virtual Machine, https://youtu.be/myWM5PE618A

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Welcome to GIS SE! As a new user please take the tour. Please don't give one-line, link-only answers - links can change or disappear over time. Instead please edit your answer to provide the steps required to answer the question - a link can be used as reference to your answer. Link-only answers will probably be deleted. – Midavalo Jul 27 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.