0

I am using apt-fast to install and upgrade QGIS-3 (2.99) under Ubuntu 16.04, which is a much faster method than the default apt-get. This works well until recently. I begin to get errors about SSL/TLS handshake failure (excerpts listed below). apt-get upgrade still works, but apt-fast upgrade consistently gives this error.

12/20 10:29:14 [ERROR] CUID#106 - Download aborted. URI=http://qgis.org/ubuntugis-nightly/pool/main/q/qgis/libqgis-gui2.99.0_2.99.0+git20171219+70d61fd+24xenial-ubuntugis_amd64.deb Exception: [AbstractCommand.cc:350] errorCode=1 URI=https://qgis.org/ubuntugis-nightly/pool/main/q/qgis/libqgis-gui2.99.0_2.99.0+git20171219+70d61fd+24xenial-ubuntugis_amd64.deb -> [SocketCore.cc:975] errorCode=1 SSL/TLS handshake failure: Error in the pull function.

...

12/20 10:29:15 [NOTICE] Download GID#b992375f94b680b6 not complete: /var/cache/apt/archives/apt-fast/qgis-common_1%3a2.99.0+git20171219+70d61fd+24xenial-ubuntugis_all.deb

...

Download Results: gid |stat|avg speed |path/URI ======+====+===========+======================================================= 5a2ca3|ERR |
17KiB/s|/var/cache/apt/archives/apt-fast/libqgis-core2.99.0_1%3a2.99.0+git20171219+70d61fd+24xenial-ubuntugis_amd64.deb 07ad77|ERR |
15KiB/s|/var/cache/apt/archives/apt-fast/libqgis-analysis2.99.0_1%3a2.99.0+git20171219+70d61fd+24xenial-ubuntugis_amd64.deb

Does anyone know how to fix the problem?

(I've tried apt-get {autoremove|autoclean|clean} to no avail.)

  • I've never used apt-fast - what is the benefit? – DPSSpatial Dec 21 '17 at 1:16
  • @DPSSpatial It's really fast, uses multiple threads to download, supports resume etc. – tinlyx Dec 21 '17 at 1:26
  • Hmmm... I'll have to try that! – DPSSpatial Dec 21 '17 at 3:22
  • I wonder why the error message has one http and one https URI. – AndreJ Dec 21 '17 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.