1

when trying to activate GniPlannerFTTH plugin on QGIS, I always get an error calles

"Couldn't load plugin GniPlannerFTTH due to an error when calling its classFactory() method"

and further

ImportError: No module named openpyxl

I successfully installed scipy and openpyxl and there were no errors that have been returned when importing them in python. I've done anything that @SIGIS wrote in Couldn't load plugin GniPlannerFTTH.

In QGIS I also get the following traceback information and the Python path:

Traceback (most recent call last):

File "C:/PROGRA~2/QGIS2~1.18/apps/qgis/./python\qgis\utils.py", line 333, in startPlugin plugins[packageName] = package.classFactory(iface)

File "C:/Users/user/.qgis2/python/plugins\GniPlannerFTTH__init__.py", line 31, in classFactory from gniplanner import GniPlannerFTTHPlugin

File "C:/PROGRA~2/QGIS2~1.18/apps/qgis/./python\qgis\utils.py", line 607, in _import mod = _builtin_import(name, globals, locals, fromlist, level)

File "C:/Users/user/.qgis2/python/plugins\GniPlannerFTTH\gniplanner.py", line 34, in from gniplanner_provider import GniPlannerFTTHProvider

File "C:/PROGRA~2/QGIS2~1.18/apps/qgis/./python\qgis\utils.py", line 607, in _import mod = _builtin_import(name, globals, locals, fromlist, level)

File "C:/Users/user/.qgis2/python/plugins\GniPlannerFTTHgniplanner_provider.py", line 32, in from planner_report import PlannerReport

File "C:/PROGRA~2/QGIS2~1.18/apps/qgis/./python\qgis\utils.py", line 607, in _import mod = _builtin_import(name, globals, locals, fromlist, level)

File "C:/Users/user/.qgis2/python/plugins\GniPlannerFTTH\planner_report.py", line 26, in from openpyxl import Workbook

File "C:/PROGRA~2/QGIS2~1.18/apps/qgis/./python\qgis\utils.py", line 607, in _import mod = _builtin_import(name, globals, locals, fromlist, level)

ImportError: No module named openpyxl

Python Path:

C:/PROGRA~2/QGIS2~1.18/apps/qgis/./python/plugins\processing

C:/PROGRA~2/QGIS2~1.18/apps/qgis/./python

C:/Users/user/.qgis2/python

C:/Users/user/.qgis2/python/plugins

C:/PROGRA~2/QGIS2~1.18/apps/qgis/./python/plugins

C:\PROGRA~2\QGIS2~1.18\bin\python27.zip

C:\PROGRA~2\QGIS2~1.18\apps\Python27\DLLs

C:\PROGRA~2\QGIS2~1.18\apps\Python27\lib

C:\PROGRA~2\QGIS2~1.18\apps\Python27\lib\plat-win

C:\PROGRA~2\QGIS2~1.18\apps\Python27\lib\lib-tk

C:\PROGRA~2\QGIS2~1.18\bin

C:\PROGRA~2\QGIS2~1.18\apps\Python27

c:\progra~2\qgis2~1.18\apps\python27\lib\site-packages\jinja2-2.7.2-py2.7.egg

c:\progra~2\qgis2~1.18\apps\python27\lib\site-packages\markupsafe-0.23-py2.7-win32.egg

c:\progra~2\qgis2~1.18\apps\python27\lib\site-packages\shapely-1.2.18-py2.7-win32.egg

C:\PROGRA~2\QGIS2~1.18\apps\Python27\lib\site-packages

C:\PROGRA~2\QGIS2~1.18\apps\Python27\lib\site-packages\win32

C:\PROGRA~2\QGIS2~1.18\apps\Python27\lib\site-packages\win32\lib

C:\PROGRA~2\QGIS2~1.18\apps\Python27\lib\site-packages\Pythonwin

C:\PROGRA~2\QGIS2~1.18\apps\Python27\lib\site-packages\wx-2.8-msw-unicode

C:/Users/user/.qgis2//python

C:\Users\user.qgis2\python\plugins\mmqgis/forms

C:/Users/user/Desktop/FttX Planner

Im struggling to interprete these information. Might there be a problem with the directory?

1

The error log tells you that it can't find the openpyxl. You might install that lib for an other python interpreter, that's is declare in you path variable.

As I can see you had install Qgis in Windows And you took the standalone installer (because it went in the programme folder). Search in Qgis programme folder the osgeo shell icon. From there run pip install openpyxl. if it doesn't have pip 2 choices get the lib from there or get the osgeo installer which is more customizable (I don't know I can say that).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.