I have two polygon shapefiles representing district boundaries: Districts1 and Districts2.

They are supposed to represent the same geographical area and same district boundaries, but I realized that Districts2 seems to be regularly offset by ~245 feet, whereas Districts1 lines up properly with the Basemap and appears to be correct. The image below illustrates an example of this, where the red shapefile is Districts2, and black is Districts1: enter image description here

I looked at the projections for the files and for whatever reason, they're different.

This is the information for Districts1:

enter image description here

And this is the information for Districts2: enter image description here

So the projection information for Districts2 looks fishy to me, but I'm not sure how to fix this... I tried projecting Districts2 into the POSGAR_94 coordinate system that Districts1 uses, but it didn't make any spatial changes. I don't know if the fact that the datum is unknown for Districts2 has anything to do with this. I also tried changing the data frame's coordinate system but that didn't do anything to better line up Districts2 either.

Evidently I'm a bit lost; I've been trying to read up on projections and datums but I can't seem to figure this out.

Edit: Michael Stimson below pointed me to the spatial adjustment toolbar, which did indeed work. However I am still interested in any insight regarding the projection discrepancy and why the shapefiles look the way they do, and specifically how I might interpret the information for Districts2 (there being no datum, the coordinate system just being "Transverse Mercator", etc.)

  • In the project dialog does it offer a transformation model? If so it should be available in ArcMap as an option for the data frame to project on the fly. If all else fails you could use the spatial adjustment toolbar to displace the one that's wrong to a more accurate position. – Michael Stimson Dec 22 '17 at 2:48
  • 1
    Wait. You have different datums, and didn't provide a transformation, and can't figure out why the layers don't align? – Vince Dec 22 '17 at 3:19
  • 2
    For a while there, all I knew about datums was, "They're the things that make data fail to align." If you have an unknown or invalid datum, the odds of getting alignment are extremely low, so step one is further research to determine what the actual datum is. It's not that there's "no datum" (every geodataset has a datum), but that it's been inadequately captured. – Vince Dec 22 '17 at 4:36
  • 1
    So evidently my knowledge of datums at this point is pretty limited, so would it be possible to determine what the actual datum is just with the information I have above, or would it be something for which I'd have to go back to the data source to find out? – nkt95 Dec 22 '17 at 5:58
  • 1
    Going back to the provider is a necessary step, but the odds that they're clueless on the topic are high, so it's not likely to end there. Unfortunately, you may need to discard this data as unreliable. – Vince Dec 22 '17 at 12:06

When faced with a geographic coordinate reference system (datum) definition that only has the ellipsoid information, the first thing that I do is look at the EPSG registry to see what geographic CRS are used in the area of interest. Putting in Argentina returns a long list of possible GeoCRS, so now I need to find the ones that use International 1909.

Unfortunately, there are none, so you would need to know that International 1909 is another name for International 1924. There are several GeoCRS that use International 1924 including Campo Inchauspe and Hito XVIII 1963. There are two others but they're for very specific areas and not District 2.

Once you've identified one or more likely candidates, redefine the geographic coordinate reference system (maybe work with a copy of the data) and try the various transformations.

When you come accross a shift of features despite the fact that the coordinate system a properly defined (which seems to be your case), this is usually because the transformation between the two datum is incorrect or unknown.

There are two ways to solve this issue.

The rigourous way

The rigourous way is to make sure that the transform is correctly defined. In addition to defining the coordinate system in the data frame properties, you must set a GCS transform. This is not done by default because there can be several transform. Note that the transform can be used both ways. If the transform is not in your list, try to find it on the Web and add it as a new transform. enter image description here

However, in your case, there seems to be another problem. Indeed, according to epsg.io, POSGAR 84 is a local WGS84 and you shouldn't need a transformation. EDIT : the problem thus seem to come from district 2, but there you only know the ellipsoid and the datum is unknown. So you could test some by trial and error, or use the pragmatic approach (see 2)

The "pragmatic" way

Sometimes, you don't find the values of the transformation because your datum is too rare, but some of the feature are homologous in the two datasets (i.e. you can find GCP's). Then you could project the data with undefined datum into the coordinate system with a well documented datum and then manually shift it. To do so, start an edit session and add the "spatial adjustment" toolbox. There are tools in this toolbox to create GCPs and adjust a model that will minimize the errors when fitting the second feature class on top of the first. This will only be an approximation, but on a small area this will be good enough for most applications.

  • The problem isn't the "POSGAR 84", it's the "GCS_International 1909 (Hayford)". – Vince Dec 22 '17 at 11:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.