1

I know there are several questions regarding issues with with $area function in the field calculator out there, however, but I could not find anything on this exact topic.

All my layers and the projects are set with CRS NAD83 UTM Zone 7. I recently downloaded the new version (2.18) of QGIS.

My $area output for the layer is huge (2241602779.0000). I know the outputs are supposed to be in meters, however, if they were in centimeters it may make sense. Is this possible? Could I have some setting wrong in my field calculator?

I tried starting a new project, setting project projection and only loading the layer of interest with the same results.

I looked at the units for distance and area measurements in the project properties, and these are both set in meters, and square meters.

I am not certain how to proceed.

  • It would be easier if you attached a link to a small test project? It should be relatively easy to do – tudorbarascu Dec 29 '17 at 6:51
  • 1
    that is 2241 sqkm - which doesn't seem that huge, but without knowing what you are mapping it is hard to say for sure. – Ian Turton Dec 29 '17 at 10:38
1

As far as I could test, it's always in square meters. It's not influenced by layer SRS nor by project SRS. There's a setting in the Configuration > Options > Map Tools submenu that supposedly lets your set your preferred distance and area units, but if it works for anything, that is not $area.

One curiosity: I created a polygon in WGS84, and tried calculating its area...

Field Calculator calculating...

As you may notice, the pre-visualization area below the input box is 8.35(...)e-05, which is precisely the area in square degrees (given that the layer SRS is in geographic coords). However, once you save it:

Attribute table afterwards

It transforms back to square meters. As I said, I observed this behaviour regardless of SRS and area output format setting.

EDIT: QGIS 2.18.10 64bits for Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.