0

I have created a batch file in Python 3.6.3 to clip a raster image using gdalwrap (I use some coordinates for clipping). Running the batch file in the command line gives error 'gdalwarp' is not recognized as an internal or external command,operable program or batch file. I tried https://stackoverflow.com/questions/31174320/gdal-merge-py-not-working-after-gdal-and-it-python-bindings-have-been-installed, but python is not recognized in this case.

  • Have you got GDAL installed? GDALWarp is an executable, perhaps it can't be found in your %path%, try executing the batch file from your GDAL install directory /bin folder. How are you calling GDALWarp from python? – Michael Stimson Jan 2 '18 at 5:18
  • Thanks for your prompt reply Michael, I use winpython and GDAL is installed. I run the GDALWarp.exe in the command lines, but it gives error ERROR 1: Can't load requested DLL: C:\Winpython\WinPython-64bit-3.6.3.0Qt5\python-3.6.3.amd64\Lib\site-packages\osgeo\gdalplugins\ogr_FileGDB.dll 126: The specified module could not be found. Could you give me a hint how to call GDALWarp in python? – Sher Jan 2 '18 at 5:33
  • 1
    It's telling you that it can find GDAL but you don't have all the packages, or that they are 32bit DLLs. Did you download GDAL from GISInternals? If so you need to also get the driver download.gisinternals.com/sdk/downloads/… and install it. I call GDALWarp from python using subprocess.Popen but if you're having trouble it might help to use the full path to GDALWarp.exe when executing. – Michael Stimson Jan 2 '18 at 5:39
  • Full path to GDALWrap.exe could solve it. Thank you very much Michael. – Sher Jan 2 '18 at 6:48
1

I've had a similar issue, I couldn't see gdalwrap from the command line or scripts. I've just noticed that it's gdalwarp, not gdalwrap. You've been writing in your messages both gdalwrap and gdalwarp - perhaps it's a typo or perhaps it's a similar issue...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.