I am building a dojo app using the ESRI JavaScript version 4.5. I built it using these instructions from ESRI:


I'm trying to render my feature layers with WebGL. In order to do this, I need to include this script tag before loading the JavaScript API into the app:

  var dojoConfig = {
    has: {
      "esri-featurelayer-webgl": 1

I downloaded the ESRI JavaScript API to my machine, so I don't have to load it into the app. Where do I include this script tag to make WebGL work?

1 Answer 1


Make sure you check out the sample application in the jsapi-resources repo.

You'll want to add that flag in the defaultConfig of the Dojo build profile. In that sample, the flag is set to 0, so you can just change it to 1 when you do your build.

Hope that helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.