When QGIS is installed, it displays the following message:

the ordinal 3109 could not be located in the dynamic library LIBEAY32.dll.

Could someone please help me.


Cuando se instala QGIS, se despliega el siguiente mesaje: "the ordinal 3109 could nor be located in the dynamic library LIBEAY32.dll." por favor alguien me puede ayudar.


I've just had the same problem on a 64 bit Windows 7 machine. I fixed it by copying libeay32.dll -

from C:\Program Files (x86)\Quantum GIS Lisboa\bin

to C:\Program Files (x86)\Quantum GIS Lisboa\apps\qgis\bin

so that it was in the same directory as the executable.

(This is the same work-around as given in the thread referenced above about a different QGIS DLL conflict.)


Judging from a simple search engine query, you have multiple versions of the same dll installed and QGIS is trying to use the wrong one. You could try searching the whole system for this LIBEAY32.dll and rename the other one temporarily. The real question is why it has search-order precedence.

  • seems like there is no way to override .dlls in system32 folder. i guess that's where the wrong .dll is hiding. – underdark Jun 1 '12 at 22:18
  • I followed the very well written instructions to the thread above and the program loaded great and is working. This solved my installation problem for this specific problem. I am using Windows 7 Professional on my HP Laptop. Thanks for solving the problem lynxlynslynx. – user17390 Apr 21 '13 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.