4

I am trying to get waterlines visualized with arrow lines, but when zoomed out I can't get them to be spacious enough.

MarkerLine Spacing - not even and too close

So as you can see on the markerline settings, i set 100 pixels as an interval, but there are awkward clusters and even if i set it to 1000, they will not get more spacious (red dots).

I have the layer in edit mode so you can also see the vertex density (the red Xs).

Any ideas how to make the interval regular and more spacious?

3

The marks are per feature, so you can expect to have a mark at the 1st vertex of each segment and if the segments are small the distance between two marks will also be small - and possibly much smaller than the distance you have specified in the style.

A workaround would be to merge features of your line layer to end up with one long line that can be properly styled.

  • In order to accept this answer from @JGH, i would need a description and or link to a tutorial with more details about how to accomplish this merge (while preserving attribute data). This seems less trivial than I hoped. – gotjosh Jan 8 '18 at 11:02
  • @gotjosh You can google "qgis merge all features" and/or start a new question. – JGH Jan 8 '18 at 12:55
2

As @JGH mentioned, they are indeed Segmented Multilines.

I found 2 workarounds:

1) Quick and not super precise: Use a matching offset and interval for the marker line settings. This means there will be no marker at each vertex and if the segment is shorter than the interval/offset it will get no marker at all and the spacing looks much better.

2) Merge the Multistring lines into Single Long Linestrings so that the interval doesn't start over at each segment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.