1

Has anyone successuflly created a layerfile (ArcGIS 10.4) to a dataset/table stored in a SQLite or Geopackage file?

Process of creating Layerfile: ArcMap TOC > Change Symbology > Right click > Create Layer file

It seems that everytime I drag in layerfile thats connected to either database, breaks or shows up but the attribue table wont work.

Adding the geometry straight in from either an SQLite of Geopackage doesnt seem to be an issue, its when I want to create symbology or categories that I would like saved for later use. Ideally I would like to create a layerfile for the Query Featureclass, though doesnt seem to ever want to work more than twice.

Seems to work no problem in QGIS as it looks better suppored, but ArcGIS is having a harder time using it.

Would love to hear from anyone who has done this succuessfully in ArcGIS 10.X

enter image description here

  • 1
    Please always present error messages as text in preference to pictures so that they are available to future searches. – PolyGeo Jan 4 '18 at 4:42
  • Haven't got access to ArcGIS 10.4 to test, but adding vector layers from Geopackage or spatialite databases works fine for me in ArcGIS Pro 1.4 – user2856 Jan 4 '18 at 4:51
  • Hi Luke, adding the geometry straight in for either the SQLite of Geopackage doesnt seem to be an issue, its when I want to create symbology or categories that I would like saved for later use. Ideally I would like to create a layerfile for the Query Featureclass, though doesnt seem to ever want to work more than twice. Will test in ArcPro to see if I get different results – Slevy Jan 4 '18 at 5:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.