2

I'm trying to save 2D data on a layer (currently to British National Grid co-ordinates) to an accurate KML version using QGIS 2.14.19 Essen. Saving directly to KML using the WGS84 CRS doesn't give an accurate result.

I have noted that accurate transformation needs to use the OSTN15_NTv2.gsb files provided by Ordnance Survey, together with an updated SRS database file - both of which I have saved down into the appropriate folders (as recommended here, for example, https://dragons8mycat.com/2016/09/26/add-ostn15-to-qgis-2-16/) but when I try to save the transformed data in QGIS (right click on the layer > Save as...) the OSTN15 CRS option isn't listed.

I have restarted QGIS etc. but I can't fathom how to try the file/coordinate system conversion using this transformation CRS.

Can anyone help, please?

  • Are you running QGIS from the OSGEO4W64 folder? anyway, it might be that QGIS 2.14 does not yet support the grid file, while 2.16 and later should do. – AndreJ Jan 4 '18 at 18:25
  • @AndreJ. I've updated QGIS via OSGEO set-up (this installed latest version of QGIS). This created a new 'qgis' folder so I copied the srs file (containing the OSTN15 ref) across to update the newly-installed srs). The old install of QGIS remained - I tried the new install: still no option to choose OSTN15 (EPSG 7709). OSTN2 (EPSG 27700) is in the old and new db too (should be accurate enough for the transformation from BNG to WGS84) but not sure if QGIS using this ref when I choose EPSG 27700 as the CRS, as result is 20m out in Google Earth. – K Jones Jan 5 '18 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.