0

I'm currently reporting an issue our users are facing in the field.

We are using QGIS / PostgreSQL to collect data on daily basis and since few weeks they are noticing a huge difference in performances with QGIS. For instance: henceforth it takes for them approximatively 10 secondes to open a single form where it took QGIS just half a second to open it at the beginning (3 months ago). All the QGIS process is slowing down, which is delaying their job and creating issues... they can't afford to wait for the "tablet" in their duty.

They are working on a Microsoft surface pro (i5, 4Go, 128Go SSD) bought in October to replace a previous tablet which was way less performant. At the beginning, the combo surface pro/ QGIS was working extremely well, with high level of performance and reactivity.

The tablet is completely offline, no updates, no connection with internet, no system modifications since the first use. It appears all the others "windows tasks" they need to do (running scripts, opening softwares) are working without any loose of performance so far.

Our QGIS project contains 6 layers, some with geometry, which are only use to open and fill forms in order to fill the database stored in PostgreSQL. The amount of data they have to enter on daily basis didn't change from the time they received the surface pro.

According to web solutions, we : - unselected all plugins and check : no difference - selected "show markers only for selected features" and check : no difference

Hence I'm running out of solutions and I'll plan to migrate back to a more stable version like 2.14 and see what it does.

Have you ever experience such a problem and/or would you have some tracks to follow ?


before installing the new version of Qgis (actually I was planning to change it to the 2.16), I tried to create a new project and it worked.

From the feedbacks of the users when we just done it, it seems to be as fast as the beginning for the moment. Nevertheless, we need to wait and see few days before clapping hands..

But why would it have solved the issue ?

any idea/suggestions ?

Simple bug ?

  • have they added a lot of data in the 3 months they have been using it? – Ian Turton Jan 4 '18 at 16:34
  • Do a complete Reformat and Reinstall (of Windows, QGIS, whatever other software) on one of the tablets and see if that improves things. – Dan C Jan 4 '18 at 16:35
  • Create a new QGIS project and add the same tables again to check if that's slow as well. – Matthias Kuhn Jan 4 '18 at 16:39
  • @ Ian Turton : they added quite a few compared to what softwares like that can handle @Dan C : I refuse to engage such manipulations because this is not solving things but just hiding problems and moreover I won't let them doing it alone (as I said I'm reporting a bug and don't have the possibility to touch the tablet because we are in different places) @ Matthias Kuhn : this is a possibility I will try to understand where this problem is coming from if this is not a version issue – FranckT Jan 5 '18 at 8:15
  • @FranckT OK, so apparently they can afford to wait for the tablet? If this problem is slowing down multiple field people and re-imaging the tablets fixes the problem for 3 months at a time, that's a fix I'd make (after investigating ndawson's much less drastic solution of course). – Dan C Jan 5 '18 at 15:04
3

I strongly suspect you're seeing the bug described in https://github.com/qgis/QGIS/commit/20197c2fa31e454b095be6b68771274ec5540c39#commitcomment-22829649.

Solution is to upgrade to 2.18.11 or higher, and then clear the existing settings to remove all the already generated junk keys which are slowing down the form.

  • will try to do so and let you know. Can we check if there is "growing files" (cf. "On Ubuntu with layers with big ids it causes configuration file to grow very fast to 10MB~100MB which make QGIS almost unusable.") on windows ? where to look for them ? thanks – FranckT Jan 5 '18 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.