1

All of a sudden, I face the issue of QGIS (2.18.15, and 2.14.21 as well) crashing when: - activating layers in the map view from previously saved files. - changing the styles / symbology of vector files, eg. categorizing after certain attributes by finally pressing 'OK'

I tried to reinstall qgis (sudo apt-get purge --autoremove qgis; sudo apt-get autoremove qgis). Furthermore, I tried to start it without loading plugins. Without success.

I currently run QGIS 2.18.15 on Debian 9.

I would like to fix this issue (and learn how it occured).

Addendum: Raster clipper doesn't work with masks from vector files.

  • Does this problem occur with every QGIS project, or only with one? What about if you create a new file? Does it occur when editing the same layer each time, or with every layer, or only with layers of a certain file type (eg shapefile versus geopackage)? – csk Jan 10 '18 at 18:27
  • It occurs with every project and file and every shapefile. I have so far tested only .shp-files, as I have not worked with geopackage files before. – se.ka Jan 12 '18 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.