I followed the instructions to install the Orfeotoolbox for QGIS 2.18 on Windows, detailed in this post. Everything worked, and the appropriate algorithms are showing under the Processing Toolbox:

enter image description here

However, while some algorithms are running successfully, when running many of the tools, I get this error:

ERROR: option -ram does not exist in the application.

So far, the error occurs in these algorithms:

  • Exact Large-Scale Mean-Shift segmentation, step 3
  • Compute Images second order statistics

I have tried re-installing QGIS and the toolbox on a different computer, and had the exact same problem. I've also tried clearing the parameter in the tool interface. Has anyone had this problem and/or knows a workaround?

2 Answers 2


After various testing the only solution I could come up with is to install QGIS 2.14 Essen alongside QGIS 2.18, then using the Orfeo Toolbox algorithms with QGIS 2.14. By default, both versions are saved separately on your computer.

This avoids the "-ram" error mentioned above, and you also don't need to install OTB again (you only need to do it once).


I had this problem and tried lots of things, what worked was to put OTB files separated from the rest. They were in program files alongside SAGA and others and I moved them to documents.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.