1

My WMS GetCapabilities response indicates it supports POST, but I cannot find how to form a valid POST request:

  <GetCapabilities>
    <Format>text/xml</Format>
    <DCPType>
      <HTTP>
        <Get>
          <OnlineResource xlink:type="simple" xlink:href="http://usalvwdgis1:8080/geoserver/ows?SERVICE=WMS&amp;"/>
        </Get>
        <Post>
          <OnlineResource xlink:type="simple" xlink:href="http://usalvwdgis1:8080/geoserver/ows?SERVICE=WMS&amp;"/>
        </Post>
      </HTTP>
    </DCPType>
  </GetCapabilities>

I've tried this:

<?xml version="1.0" encoding="utf-8"?>
<GetCapabilities service="WMS" version="1.3.0" xmlns="http://www.opengis.net/wms"></GetCapabilities>

But receive this error:

Could not parse the XML for: org.geoserver.wms.GetCapabilitiesRequest

I've skimmed 06-042_OpenGIS_Web_Map_Service_WMS_Implementation_Specification.pdf for clues of how to convert the GET request into a POST request, but I could not come up with a working version.

I've also looked at https://github.com/geoserver/geoserver/blob/2.12.x/src/wms/src/main/java/org/geoserver/wms/GetCapabilitiesRequest.java and

  • Actually, <GetCapabilities/> is enough when I hit the correct URL! usalvwdgis1:8080/geoserver/ows?SERVICE=WMS But the version attribute must also go on the query string, which contradicts the documentation which says no addition parameters are needed. – ca0v Jan 11 '18 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.