2

I'm encountering a very peculiar bug in ArcMap 10.5. I have an mxd I created as part of a large project, and when I attempt to save edits to a feature class from the project's file geodatabase (~38 GB) ArcMap freezes every time. Initially I suspected that either my mxd or geodatabase had been corrupted, but I can successfully save edits to shapefiles from different directories in the same mxd AND save edits to feature classes from the same geodatabase in different mxd's. Perhaps it's something about the particular combination of layers that are added to the dataframe? I really don't know. Everything is in the same projection and I haven't encountered errors running any other tools or processes. Without success, I've tried:

  • Clearing the geoprocessing history and image cache
  • Compacting the geodatabase in ArcCatalog
  • Running MXD Doctor on the map file
  • Copying the geodatabase and changing the data source to the backup
  • Copying the data frame from the original mxd to a new map and editing in that window
  • Whitelisting the directory the geodatabase is stored in in my antivirus (Windows Defender)

Edit: The File Geodatabase is local, not in a network location. No other programs are trying to access the files simultaneously. In reference to a few of the other questions, the number of features in the layers being updated varies-- the problem is not confined to any particular feature class or layer. It happens when trying to save edits to any layer in the geodatabase unless I edit them in a new map with only one or a small subset of feature classes added.

Edit 2: Yes, the geodatabase contains a number of large rasters and shapefiles that cover an entire state. But it's not even close to the storage limit by total file size or number or files, so I'm not sure that would be the issue. I haven't had any issues editing until a day ago. I tried compacting the geodatabase this morning with no success. I'll give compression a whirl and see if that helps.

  • How large is your file geodatabase? MS Access? – MaryBeth Jan 11 '18 at 20:46
  • The geodatabase is 38 GB. It's in the standard ESRI File Geodatabase format. – lambertj Jan 11 '18 at 21:12
  • 2
    Please edit the question in response to requests for clarification. Some additional properties to document: The number of features in the table being updated. Whether the file is local or a network share. If networked, is the drive mapped to a letter drive, or are the references accessed by hostname and sharename? In truth, this is the sort of thing to take to Esri Tech Support – Vince Jan 11 '18 at 21:22
  • 38 GiB is a huge file geodatabase, why is it so large? lots of rasters? when was the last time you compacted the database? What configuration keyword are you using? Do you have any other Esri product looking at the features in this database.. or have looked and moved on? (locks tend to persist until the product is closed). You could try compress and uncompress (on a copy!) to reset the delta tables. – Michael Stimson Jan 11 '18 at 21:27
  • A very interesting problem.. have you got space in your %TMP% folder? ArcMap creates a folder in %TMP% named arcXXXX, where XXXX represents a hexadecimal number like 1F3B for example, this is where the edits are stored temporarily, it might help to exclude these folders from Windows Defender. If you're not sure where %TMP% is start a command window and type SET TMP, hit return and you will see what the value of TMP is; I suggest this way because some system administrators disable access to advanced system settings (Control panel\System\Advanced system settings - environment variables button) – Michael Stimson Jan 11 '18 at 23:20
3

A few other things I usually try if a feature class is giving me some kind of problem:

  1. Use the Feature Class to Feature Class tool to make a copy of the problematic feature class. Try copying the problem FC to a new FC in the same GDB first, then a different GDB, and if neither works, a shapefile.

  2. Open a fresh ArcMap session, add only the problem feature class to it, and try your edits.

  3. Try editing the feature class on another machine entirely.

  4. If it's one particular feature that you can't edit, copy that feature to another FC, edit it there, then delete the original feature and copy the edited one back into the original FC.

  • 2
    All very good tips, +1 from me. If these 4 don't work my step 5 is to export to an XML workspace, create a new GDB and import the XML workspace... this reestablishes the system tables (the tables that exist but you don't see) and can fix even moderately corrupted data. – Michael Stimson Jan 11 '18 at 21:30
  • Thanks for the suggestions. Unfortunately, the problem is not restricted to any particular feature class. Just for kicks, I gave Feature Class to Feature class a try within the same session, but no success. Opening and editing single feature classes from the same database in a new session does work, but that doesn't really solve the issue. – lambertj Jan 11 '18 at 22:13
  • After trying a ton of different solutions suggested by ESRI support and the fine folks here, I decided to give Feature Class to Feature Class (and raster equivalent) another go for all the layers in my problematic GDB. I set the destination as a fresh GDB. This seems to have fixed the problem. Thanks a lot for the help! – lambertj Jan 16 '18 at 18:22
2

1.Try to run 'repair geometry' tool. 2. Check the indexes of the FC, if it is not exist rebuild it or calculate from new. 3. Be sure that you FC not used in another application and lock your FC.

Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.