2

I'm having a hard time trying to expand a raster within a mask. Here are some details about my case:

I'm working with glacier ice thickness rasters, which happen to be smaller than the real size of the glaciers, specified by a vector polygon which I'm using as a mask. My goal is to expand the ice thickness raster within the polygon by interpolating the raster with the borders of the polygon which should be 0 (meaning no ice). I've tried to address this problem in multiple ways, and I have ended up converting the raster to points and the borders to points with value 0 and merging both layers. Here is what I have so far tested:

Glacier ice thickness raster converted to points

When I try to interpolate the points using different interpolation tools I'm getting this error message: 'NoneType' object has no attribute 'crs' See log for more details

I have also tried doing the same but directly with a raster file (with the ice thickness raster added surrounded by 0 values), and trying to interpolate it with the glacier polygon mask.

enter image description here enter image description here

I've been using GRASS' r.surf.idw tool, but I can't get it to work. Despite having the raster file and the polygon file with the same CRS, I see a warning label on top of my screen saying Warning: The projection of the chosen layer is not the same as canvas projection! The selected extent might not be what was intended.

The results always look like this:

enter image description here

Anyone has any ideas on how to tackle this issue?

  • What CRS are both your layers AND the project set to. If you changed the CRS of any layers, did you save them with a new one or use the reproject tool? – firefly-orange Jan 12 '18 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.