3

When I execute the Erase Tool in ArcGIS it does not erase all of the features in the input class. The Input and Erase features are both polygons. I have attempted multiple times, hoping it was just a fluke.

Here is what I have tried so far:

1) I have selected out the specific features from the input that aren't being erased and attempted to run the Erase with those, but the output shapefile ends up being completely empty.

2) Using the Clip tool instead. The effects are the same.

3) Made sure when I run the Erase that no random features are accidentally selected.

EDIT:

4) Repair Geometry of input.

5) Rebuild Spatial Index of input.

6) Making sure input featues (erase featues) are not multipart via a)Dissolve and b) Multipart to Singlepart Tool. The latter produces a shapefile that is missing the 3 polygons that are causing trouble during the Erase function.

Does anyone have experience about how to fix this problem?

Input features: enter image description here

Output feature. The bottom half of the polygon is where the trouble is: enter image description here

  • 1
    If your data is in Shapefile format, you can update the Spatial Index. Also, you can run Repair Geometry to fix any invalid polygon geometry. – klewis Jan 12 '18 at 18:25
  • @klewis Thanks for the response! I just tried both of those and neither worked. Additionally, I attempted to Dissolve the features in the input shapefile (to try Erase again). – MoreMeowbell Jan 12 '18 at 19:00
  • 2
    Make sure your spatial extent equal union of inputs. – FelixIP Jan 12 '18 at 19:14
  • @FelixIP Thanks! How would I go about doing this? I am still somewhat green when it comes to more advanced ArcGIS processes. – MoreMeowbell Jan 12 '18 at 19:28
  • 1
    It likely might be the extents per @FelixIP - click Environments... and in the "Processing Extent" drop-down select "Union of Inputs" - report back if this fixes it or not! – AlecZ Jan 12 '18 at 19:33
3

Click Environments... and in the "Processing Extent" drop-down select "Union of Inputs" - the extents are set to "Default" normally. The tool will only execute the function in the area designated, so "Union of Extents" will ensure that all features are removed from the input geometry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.