2

I`m trying to add a layer to QGIS connecting to a WMS server but I got this error:

"The server you are trying to connect to is not a WMS server. Please check the URL"

I tried two different URLs but I got the same message. Here are the URLs:

http://www.snirh.gov.br/arcgis/rest/services/SNIRH2016/Precipitacao_isoietas/MapServer/1

and

https://services.arcgisonline.com/arcgis/rest/services/Elevation/World_Hillshade/MapServer

What I'm doing wrong? Sorry for the newbie question.

Step 1:

New connection and URL added

Step 2:

This is the message I get

Here is the detailed message:

"Em vez da string de caracteres de recursos que era esperada, foi recebida a seguinte resposta: (in portuguese)"

translated:

"Instead of the resource string that was expected, the following response was received"

  • 3
    mmh does this have anything to do with the GeoServer?...you might want to rephrase the title maybe? – ThingumaBob Jan 13 '18 at 10:00
4

You need to use the WMTS URL given at the top of your page: https://services.arcgisonline.com/arcgis/rest/services/Elevation/World_Hillshade/MapServer/WMTS/1.0.0/WMTSCapabilities.xml

For the other server, I did not see it, it looks like it does not implement standard WMS.

1

You connect to ArcGIS rest services using a different method. As outlined in adding arcgis online services to qgis, for QGIS version 2.16, you follow these steps:

  1. Layer - Add Layer - Add ArcGIS FeatureServer Layer...
  2. New (for a new connection). Give a name and enter your address in field URL.
  3. Connect (connect to service to fetch layers).
  4. Select layer.
  5. Add.

If you follow the link, there are answers for other QGIS version too.

  • I did those steps however when I tried to connect I got an error: The server you are trying to connect to is not a WMS server. Please check the URL – Henrique Veiga Jan 13 '18 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.