1

I have a multipart feature class, with 511 features. The sum of the area is 84,083 hectares. However when I dissolve this feature class, the total area has changed to 83,467 hectares. Areas were calculated using Calculate Geometry operation. Projection and coordinate system are the same.

How could this happen?

I have used erase, intersect, clip and symmetrical difference - none of these geoprocessing tools could detect the difference.

  • How do you calculate the area? – BERA Jan 15 '18 at 12:39
  • 1
    Did you convert the multipart to singleparts before you ran those tools? – Joseph Jan 15 '18 at 12:39
  • 1
    I bet there are small overlapping areas, counted twice before the dissolve, but not anymore after. – GISGe Jan 15 '18 at 12:49
  • @BERA Using Calculate Geometry tool – rudster Jan 15 '18 at 12:51
  • @Joseph No I didn't. Should I try? – rudster Jan 15 '18 at 12:51
7

If you have overlapping features, the dissolve tool will merge those overlapping areas and make the overall sum of the polygon areas smaller.

This doesn't mean all the overlaps have disappeared. Only the overlaps between identical values must have been cleared. Please see example below to understand the process :

In this example, you have

  • 3 polygons : 1 polygon A, 2 polygon B, all identicial
  • 100m² each, so overall area is 300m²
  • all overlapping each other

example 1

When i dissovle on the Name field, I get

  • 2 polygons : A name polygon, B dissolved polygon
  • A polygon and B polygon still overlap
  • overall area is 100+177 = 277m²

I guess that is what happend to your data and that is what explains why the area has decreased.

example 2

The conclusion is also that your data must not be topologically correct. Please check your data to avoid overlaps to avoid this kind of results (@GISGe & Joseph have hinted this answer, and I agreee with them).

The usual arcgis overlay tools can do a lot of things between layers but not inside a layer, that's why they don't detect any problem.

SOLUTION

You need to solve the overlapping problem and make sure there is no multipart feature (it can be painful dealing with those).

A efficient way to solve your problem is to separate your values in as many layers as unique values after dissolving, then unionize the layers all together. You'll be able to have a single flat geometry (and have the area), while not loosing the overlap information.

in my example : you need to get the dissolved A+B layer, then split in A layer and B layer. Then you unionize A layer and B layer.

you'll be able to know what is the A area, what is the (A AND B) area, and what is B area.

It can be time-consuming if you have a lot of unique values.

BONUS (if you don't care about the attributes)

If all your data must be dissolved together with no attribute distinction, just leave the optional 'Dissolve fields' parameter empty, and you'll have a big dissolved polygon with no overlaps

(Thanks @GISGe for the tips)

  • 1
    Regarding the BONUS section: it is not necessary to add a dummy field if you want to dissolve all features. Just leave the optional 'Dissolve fields' parameter empty. – GISGe Jan 15 '18 at 14:00
  • Oh, nice, thanks for the advice :) I'll edit my answer....Nb : years of creating my dummy column for nothing haha :/ – gisnside Jan 15 '18 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.