3

I have 3 layers and a basemap. 2 layers align nicely with the google basemap and accept it´s CRS which I have set as a project CRS and also enabled on the fly reprojection. I have also selected it as a default CRS and ticked the ´use project CRS´ in SETTINGS - OPTIONS - CRS. These are all options I have found reading people´s comments.

However when I add the third layer it does not appear on the map. It will only appear if I change the CRS back to it´s original one which is different to the one the other layers are in. I have also tried saving this layer with the desired CRS and re-opening it but still won´t appear.

The CRS I want to use for the project is ESPG 3857 or ESPG 4326 but the layer only accepts Krovlak.

Any tips on how else I could proceed?

  • 2
    that is how it is supposed to work, one of your layers is in a different projection than the rest. Turn OTF on and set the project CRS to the one you want – Ian Turton Jan 16 '18 at 13:31
  • 2
    Load each layer one by one into qgis, save each one into the same CRS, then load all of them into the same project and things should work out. – Erik Jan 16 '18 at 13:40
  • 1
    It sounds like the third layer crs is not defined correctly, otherwise it would align with the other different crs layers with the "on the fly re-project" setting enabled. – artwork21 Jan 16 '18 at 13:59
1

Does it not appear, or does it appear in the wrong place..?

Regardless, I've had a similar problem. The way I've fixed it is by the method in Erik's comment - load each one in one by one, then save each into your desired projection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.