2

I'm working on a EPSG:32721 project that works just fine. I'm trying to add a new vector to this project, but I just can't find the way to align it with my others layers.

What is very strange is that this new vector is also part of the bigger layer from where I took the layers of my project (the original layer was a landcover layer from where I selected specific features that I saved as different layers with a metric projection - UTM 21S).

I tried everything I could find about projection problems on this forum, but I could not fix it. I saved my layer with right click and selected the projection that I wanted. OTF is activated. Nothing. The new vector is showed way out of the extent of the others layers.

What I can tell is that the coordinates are different, even if the CRSs matches. This is a screenshot of the information of one of the project's layers:

screenshot1

And this is a screenshot of the proprieties of the new layer:

screenshot2

How can I fix this?

UPDATE

I didn't know how to select a vertex, so I selected the polygon that I would like to save as EPSG: 32721. Is this what you asked? screen

  • The extent of your second image looks reasonable, but locates to Paraguay, where I can't find any Santa Ana nearby. Where should the data be? – AndreJ Jan 16 '18 at 18:06
  • yes, my data are located in Paraguay. Santa Ana is a private estate. – Salvatore Valente Jan 16 '18 at 18:37
1

The problem is in your human21S layer. Metadata says it has one polygon feature, but if you check the extent, it shows that xMin and yMin are respectively equal to xMax and yMax. Meaning your one feature has no measurable geometry. Also, the values of 8 million East are preposterous, this is no UTM.

What might have happened is that this layer was in one CRS, then its reference was manually changed to another, and saved as such. The easiest way to fix this is by creating your layer-from-selection again.

Edit: ok, by your wkt image, I can see that your layer's coordinates are in geographic (lat/lon), but the layer's CRS is incorrectly set to 3857, which is projected (x/y). What you need to do to set this straight is change your layer's CRS to a geographic one (impossible to know which one was used at source, but WGS84 - 4326 - is your best bet), then save you selection to whichever CRS you desire. This should properly reproject your coordinates.

  • What do you mean when you say "its reference was manually changed"? Anyway, I opened the original layer, selected the polygon that I needed, right-click and saved (just the selected feature) as EPSG: 32721. The result is the same. The new layer has still no measurable geometry and I cannot align it in my project (but I can do it in the original layer with OTF activated). The original layer is projected as EPSG: 3857. – Salvatore Valente Jan 16 '18 at 18:36
  • The CRS is just a reference, the coordinates don't change. One can change the reference at will, but this will generate errors when saving (as QGIS will understand it to be in the correct CRS, even when it's not). Can you post here a sample coordinate of the original layer? The first vertex should be enough. You can do so with the getWKT plugin. – Roberto Ribeiro Jan 16 '18 at 19:52
  • I updated the post in order to post the image of the getWKT plugin. – Salvatore Valente Jan 16 '18 at 22:05
  • Ok, I expanded the answer to address your specific case. – Roberto Ribeiro Jan 17 '18 at 0:40
  • So, I reprojected my layer as WGS84 4326 and if I try to get the coordinate through WKT I get the following kind of coordinates: Polygon ((-0.00052140403886989 -0.0002412142094151, -0.00052140403886989 -0.0002412142094151, -0.00052140372255061 -0.00024121383589076 But when I try to save it as UTM 21S, I still can't align it with my project and the coordinates that I can see on the bottom are just as the one that you can see in the second image that I posted. Nothing seems happened. – Salvatore Valente Jan 17 '18 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.