1

I am not sure whether someone ran into similar problem. I've been using PyScripter with Arcpy for the past two years and I have been happy with it most of the time.

Yesterday I ran into a kind of weird problem. I wrote a pretty straight forward and simple script. Basically it reads through text file, gather information and then based on the information gathered running first a attribute search on a given layer (arcpy.SelectLayerByAttribute), then union all the geometry that have been selected, then insert to a newly created featureclass.

I have to do this a lot of times for the whole US nation.

The codes runs fine in Pyscripter then it crashes at about 18505 times of selecting layer, with an error message saying 'EOFError Timed Out', then pyscripter freezes. I cannot shut it down but clicking 'x', it kept telling me it's in debug mode. I have to shut it down using task manager.

I tried to re-run at the data from where it stopped and this time it runs fine all the way till it hits ~18505 again. I tested about 10 times on different data and it always crashes at ~18505 times doing SelectLayer.... I've been stuck there for a whole day.

Then finally I decided to run the script in command line and it runs all the way till all the data are done.

I wonder if there's a limit set somewhere in pyscripter? I like the ide and want to continue to use it. But this is very frustrated. I don't want to run it to this and waste a day again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.