I have 2 Shapefiles in CRS 21781. The first one "Gebiete" shows some areas within a ski resort in switzerland. It is downloaded from a WebGIS based on OpenLayers 4 in which it was generated. The second one "Lifte" shows lifts within that same ski resort. This one is exported from ArcMap as a shp, where it was generated.

When I open a new empty project within ArcMap and first add the layer "Lifte" and then the layer "Gebeiete", the layer "Gebiete" is not visualized correctly. Check out the picture and the coordinates in the bottom left corner. enter image description here

When I zoom to the layer "Lifte" I get the correct coordinates. enter image description here

The really interesting thing is that according to the properties, they both are in the crs 21781 but have a slightly different name.... enter image description here

When I first add the layer "Gebiete" I get the correct position and then add the layer "Lifte", "Lifte" is not on the correct position. There must be a problem with the crs, although I kind of thought that if you have the same EPSG codes you are in the same crs...

Honestly I have no clue what's going on here...the prj files are also different, as the ArcMap generated shp doesn't include any EPSG codes, not like the OpenLayers generated shp.

enter image description here

When I open them in QGIS 2.18.15 there is no problem at all. enter image description here

Does anyone know where this problem comes from?

1 Answer 1


Since it is the same projection, just replace content of Gebiete.prj with the content of Lifte.prj.

  • I think ArcGIS is reading and converting the rectified grid angle parameter to xy plane rotation, but it's not needed for this Swiss CRS.
    – mkennedy
    Commented Jan 17, 2018 at 19:25
  • this would fix the problem of the visualization, but doesn't fix the problem that I generate two files with same crs but are not visualized correctly. I will rephrase my question :)
    – rabear
    Commented Jan 18, 2018 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.