1

I had QGIS version 2.18.14 installed on my ubuntu. Today I wanted to make an update, but some problems came up. So I deleted QGIS and wanted to reinstall it. But everytime I try to reinstall it, this comes up:

The following packages have unmet dependencies:
 python-qgis : Depends: libqgis-analysis2.18.15 but it is not going to be installed
               Depends: libqgis-server2.18.15 but it is not going to be installed
               Recommends: liblwgeom-dev but it is not going to be installed
 qgis : Depends: gdal-abi-2-2-2 but it is not installable
        Depends: libqgis-analysis2.18.15 but it is not going to be installed
        Depends: libqgis-app2.18.15 but it is not going to be installed
        Recommends: qgis-plugin-globe but it is not going to be installed
        Recommends: qgis-plugin-grass but it is not going to be installed
        Recommends: qgis-provider-grass but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

How can I fix this problem?

marked as duplicate by aldo_tapia, Kersten, whyzar, underdark qgis Jan 17 '18 at 16:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged or ask your own question.