2

I am trying to interpolate temperature values into a raster using QGIS 2.18.15 in Windows. I need the output file as a GeoTIFF (.tif) file. I have my input for temperature already in a shapefile, but whenever I try to execute the command, it shows a Python error.

These are the procedures I have taken enter image description here

But it shows me this enter image description here When I click Stack trace it says this:


An error has occurred while executing Python code:

UnicodeDecodeError: 'ascii' codec can't decode byte 0x83 in position 32: ordinal not in range(128) 
Traceback (most recent call last):
  File "C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python/plugins\GdalTools\tools\widgetPluginBase.py", line 88, in onFinished
    self.base.onFinished(exitCode, status)
  File "C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python/plugins\GdalTools\tools\dialogBase.py", line 208, in onFinished
    msg = unicode(self.process.readAllStandardError())
UnicodeDecodeError: 'ascii' codec can't decode byte 0x83 in position 32: ordinal not in range(128)

Python version: 2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)] QGIS version: 2.18.15 Las Palmas, ac2d111ed1

The message log says this:

2018-01-18T19:04:55 1   Traceback (most recent call last):
              File "C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python/plugins\GdalTools\tools\widgetPluginBase.py", line 88, in onFinished
                self.base.onFinished(exitCode, status)
              File "C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python/plugins\GdalTools\tools\dialogBase.py", line 208, in onFinished
                msg = unicode(self.process.readAllStandardError())
            UnicodeDecodeError: 'ascii' codec can't decode byte 0x83 in position 32: ordinal not in range(128)

What I should do?

Here is a link to my shapefile https://drive.google.com/file/d/17At2G7yBLRxSrWhS9yhIKIJBs8R0iHd_/view?usp=sharing

closed as off-topic by nmtoken, Vince, Midavalo Jan 21 '18 at 20:50

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – nmtoken, Vince, Midavalo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Change path name to include only latin characters. – Vladimir Jan 18 '18 at 10:14
  • A shapefile consists generally of multiple files in the file system (generally .dbf, .prj, .shp, .shx, .qpg). You need to zip all of them and provide, otherwise it is impossible to open. – 15Step Jan 18 '18 at 11:00
  • My guess would be because you have non-ASCII characters in your file path (ソフト). Try saving your tif to a directory path with only ASCII characters; does it still produce this error? – Roberto Ribeiro Jan 18 '18 at 11:07
  • Yes! I changed my file path to english and the execution went through properly! Thank you very much! – tonaminato Jan 18 '18 at 13:19