0

I have an in house WMS server running on Ubuntu Linux and using MapServer to serve a WMS layer for my various bits of GIS software.

The server works perfectly fine, but it does take a little while to create a map if it's very large.

I have a tile layer for example that covers a very large area of the north east of England, from Blyth right down to North Yorks, and from the Pennines out past the East Coast.

Loading this WMS layer into QGis (as an example) is perfectly fine, as long as I Zoom in, and don't zoom out too far, and since I'm using this as background mapping to see where I need to draw things, then it's not an issue. Mapserver produces the map, for the area requested.

My problem with all of this, is when I use Autodesk Map3D.

It accepts the WMS connection fine, but no matter how far in I'm zoomed, every time I try to add the WMS connection it tries to add the entire map into the Map3D project. This (because of the size of the map) times out every time, thus preventing me from adding the background map to my project.

Does anyone here know how I can get Map3d to only load the area under the view port, then load the other parts as needed when I scroll.

As I say, QGis seems to do this perfectly fine, and even my Open Layers web viewer Iv'e written works perfectly too, but Map3d just will not, and right now I can't seen to find any sensible answers anywhere.

  • >Display Manager and select Query to View should get you what you want. – Mapperz Jan 18 '18 at 14:31
3

I don't know any way to prevent AutoCAD Map 3D from zooming out when adding a WMS connection via FDO.

But this might help as a workaround:

  1. Try to load the service at least once to AutoCAD Map 3D. Save the layer als a .layer file.
  2. Add maxscale here in .layer: enter image description here
  3. In future: do not add WMS via FDO dialog. Instead drag and drop the .layer file to map. The map will zoom out but the contend of WMS is not visible.
  • Hi, so been trying for a few hours to see where to save a layer file, only to realize that it actually has to show up in my display manager first, before I can do this. In my case, I'm not even getting as far as getting the layer in my display manager. I basically click, 'add to map' in my data sources, then it sits there not showing me any feedback, and basically hangs Map3D and at some point later usually after a few minutes, Map3D springs back to life with a yellow bubble int he bottom corner telling me it timed out. – shawty Jan 18 '18 at 17:49
  • Try to add an other WMS whitch works (e.g. geo4.service24.rlp.de/wms/… ). Then save this to .layer file. Then try to change contend of .layer to fit your service. – Jens Jan 18 '18 at 18:10
  • Sorry. I have tried to adapt the. layer to the other WMS Service as suggested in my last comment - but unfortunately it doesn't work for me. – Jens Jan 18 '18 at 18:41
  • Had to step away from PC. The idea makes sense, so lets see if I can make it work. It'll not be the first time I've had to do similar tricks in the past :-) – shawty Jan 18 '18 at 18:49
1

Not quite a direct answer, but did help me solve the problem, sort of :-)

The timeout, after further analysis was actually coming from "Apache" not from Mapserver, and certainly not from Map3D.

Basically, Map3D was still requesting the entire map, and Mapserver was generating it, but Apache was timing out and killing the Mapserver process after a couple of minutes, presumably because it had thought it had crashed.

After I changed the timeout value in my Apache web server configuration for the path that I had set up to call map server to produce the WMS, I managed to get it to work.

It's still not the best solution, because it takes Mapserver 31+ minutes to generate a 640x480 of the map.

Unfortunately after closing then re-opening my Map3D project, it sits and waits for over an Hour to actually load the project, while it waits for the map to be produced.

I solved the time-out, but still need to see if I can get Map3D to not ask for the whole map, and only the area in the Viewport, which is exactly what QGis does.

UPDATE - 3 Days Later

So, try as I might, I just cannot get Map3D to stop trying to load the entire map at startup, re-adding the layer, or in a lot of cases even on panning the map.

The only way Iv'e been able to reduce the footprint, is to change the map extents parameter in the map script definition file that map server uses to generate the file.

Making that smaller, did mean map3d requesting a smaller map, but unfortunately, it also meant that panning outside those boundaries just resulted in mapserver returning white space, as it believed there was no map data there.

In time, I might figure the Map3d side of things out (Sorry Jens, but the saving and altering of layer data as per your comment didn't work in this case, points for trying though :-) )

However, since the actual timeout was due to the configuration of the underlying web server, then technically the answer is to change the timeout under the web server configuration.

This will stop the error, but depending on how you configure it, you may have to wait a long time to load the map.

I'm marking this as the answer for now, but I have a feeling that this is not the end of my re-visiting this...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.