2

I'm using Windows 7 and I'm having the problem of QGIS 2.18.16 crashing with any shapefile. Rasters seem to be OK. I have tried uninstalling and reinstalling 2.18.15, 2.18.14 and one older version (2.17 or earlier, I can't remember). I turned off all plugins before trying anything. I found earlier advice about changing a registry key, so I used the Windows command line to start regedit and under HKEY_CURRENT_USER> SOFTWARE> QGISI deleted all the QGIS and then did the 2.18.16 install. I also downloaded the OSGeo4W version and tried running QGIS from that.

I haven't tried any other vector formats because I really need to work with shapefiles. I'm not having any trouble with my desktop, just my laptop. I was using the style editor when the trouble first appeared.

I looked all over at the other posts about this problem, like qgis-bin.exe stopped working and I'm not sure how to provide more information.

Edit: I tried loading a geodatabase with vectors, it worked and I changed a few symbols and saved. Upon exiting I received this same message and now I get this fail when I try opening geodatabases. I also get this fail when I'm loading the new project (with just this simple geodatabase loaded).

  • Are you sure you have full write permission in the folder where you have stored the shapefiles? – AndreJ Jan 21 '18 at 19:25
  • Yes. I have also tried many directories. – Geocurious Jan 21 '18 at 20:49
1

I found the problem. I was cleaning everything out on before reinstalling, but I didn't realize that in windows, the plugins are in a file that starts with a dot: I had to delete this: " C:\Users\myusername\.qgis2 " directory then restart then reinstall I also followed a tip elsewhere and deleted the Windows registry Software key (with the registry editor) HKEY_CURRENT_USER > Software > QGIS I don't know if that helped.

  • should be C:\users\myusername\.qgis2 which might be hidden on some Windows OS versions. – AndreJ Jan 27 '18 at 6:27
  • Yes! It's one of those odd html things about putting "\" and "." next to each other. – Geocurious Feb 21 '18 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.