0

I select a column chart for symbology in ArcMap.

How do I put the values of the parameter under the columns?

Here is an example of what I want to make: column char

1

I am not sure how to do this from the symbology tab, however a possibility would be to work with the labeling of the points (assuming the symbology is based on a point feature). Using the Maplex Labeling Labeling Engine (assuming you have ArcMap 10.3 or more, or an Advanced License for older versions).

If you are using a Polygon Feature, try converting the Polygon to a Point Feature at its centroid and use that for labeling the values you want to use - or even the symbology)

See here for a detailed explanation: ESRI Tutorial for Enabling the Maplex Engine

This gives you more functionality when it comes to placing labels. So you should be able to place the symbology, and control where the label is placed beneath it.

You can change the X and Y offsets of both the labels to ensure the labels and symbols are aligned as you need.

To find the options of the offsets: "Labels Tab" -> "Symbols" -> "Edit Symbol..." -> "General"

2
  • I followed the instruction, but it partially worked. In some columns the value is placed where I want it (exactly under the column), but in other it leaves a big gap. and if I change the offset, all the labels are moved. I would expect that the issue would be handled only by symbology, but I haven't find anything despite trying a lot – cartographer67 Jan 23 '18 at 8:37
  • @andreas76 Unfortunately I am not too sure how to proceed from here. An alternative would be to create a field in the layer you are using to label the feature. Assign a value of 1 for those labels that work, and another value for those labels that need to be offset. Under the labeling tab you can choose to label features individually based on a field value. You can then separate out those labels that need to be offset and assign the correct offset. Again, I am not sure if this is the best way, but it is where I would start. – Keagan Allan Jan 23 '18 at 10:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.