0

I have successully installed and configured CartoDB in Ubuntu 14.04 LTS VM and could also view the main page of CartoDB interface and login into my development account. But when I try to import any file (CSV or shapefile in zip format), I am getting import error which is decribed as follows.

Error Code : 2001

Error Description : Unable to load the file into database

I have also tried with updating ogr2ogr to ogr2ogr2 as mentioned in the post "https://groups.google.com/forum/#!topic/cartodb/xI15ygEy4Fo" but with no success. Also I have set 777 permissions to /tmp folder. Note my GDAL version is 1.10.2.

  • You should not ever change the permissions on system folders, but if you do, you should set them correctly... the correct access flag for /tmp is 1777. – Vince Jan 23 '18 at 11:17
  • Ok @Vince... Is there any way to make the import functionality work in Ubuntu 14.04? – Dinesh Jan 23 '18 at 11:55
  • No clue about CartoDB, but your "fix" could have prevented a solution, and caused all manner of other OS failures, so it was important to raise the issue. – Vince Jan 23 '18 at 13:21
  • Any idea on this? I am trying for weeks but no solution – Dinesh Jan 30 '18 at 13:38
1

I could successfully import data (CSV and GeoJSON) in cartoDB now. The problem was I had GDAL 1.10 previously installed and now being upgraded to GDAL 2.1.3 which resolved the issue. Moreover the cartoDB is working fine for import dataset in Ubuntu 14.04 and Ubuntu 12.04 by just following the instructions "media.readthedocs.org/pdf/cartodb/latest/cartodb.pdf";.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.