0

In QGIS 2.18.15, I open a project and my component shapefiles have migrated to the west coast of Africa. Here's what's leading up to this:

  1. I've disabled OTF on startup since there are well-documented geometry calculation issues that arise with OTF enabled.
  2. My default projection is set to EPSG 102710 (NAD 1983 State Plane New Hampshire US Feet). All component shapefiles are projected to this as well.
  3. When trying to calculate acreage for various polygons, these calculations are wonky, thus:
    • The "output preview" for the expression $area / 43560 correctly displays acreage, and yet:
    • The calculated column in the attribute table returns a value that is 1/10.7639 of the actual value. There are 10.7639 square feet in a square meter.
  4. When I add a new vector layer, the "selected CRS" always displays as WGS 84 and I must manually select EPSG 102710, even though this is set to the default.

So it seems QGIS is defaulting to WGS 84 and metric measurements. If I turn OTF off, my shapefiles return from the African Atlantic to their rightful places in New Hampshire.

I do have several QuickmapServices layers included in my project.

Happy to provide other info if needed.

  • Additionally, if I enter the Project Properties and turn on OTF, I can select EPSG 102710. If I then deselect OTF, the selected CRS jumps right back to WGS 84. Is this a feature or a bug? – Nick Lanzer Jan 24 '18 at 15:09
1

What have you set with your bullet 2). Is it the default CRS for new projects or the CRS for new layers?

enter image description here

  • I have "Use project CRS" selected. The project CRS default is set to 102710; shouldn't the second and third choices then do the same thing? – Nick Lanzer Jan 24 '18 at 16:03
  • Perhaps yes but it is rather cheap to have a try with Use default CRS. – user30184 Jan 24 '18 at 16:04
  • Thanks for the suggestion - didn't seem to do much though. – Nick Lanzer Jan 24 '18 at 16:33
  • I suggest to use Prompt for CRS to avoid any unwanted results. – AndreJ Jan 24 '18 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.