1

I previously had 10.5 and opened up an ArcGIS 10.2 versions MXD. This week, I upgraded to 10.6 and tried to open the MXD from that same 10.2. That MXD would not open. All it would do is "not responding". I copied, renamed it and even re-downloaded it from the email it was sent from. Nothing. Corrupted?

I opened up older mxd's of mine when I had 10.1. Another Mapper used different versions 10.5 and 10.2, could not open that one either. But, could open others.

Are there any solutions?

5

It could be something in that particular MXD is corrupt. You could try two things.

The first is to run the "MXD Doctor" it normally comes with the installation of ArcMap. I am not sure if it comes with 10.6. Normally it is found in (using Window 7): Start -> Programs -> ArcGIS -> Desktop Tool -> MXD Doctor

I have had some success in using this tool to recover corrupted MXDs.

Another alternative method, would be to check the Data Sources of the MXD. It is possible that perhaps a layer in the MXD is creating the error. Open ArcCatalog and navigate to the MXD giving issues, Right Click and select "Set Data Sources". This opens a window with all of the data loaded in the MXD. Try checking each data source to ensure it is reading information from the correct locations.

I have had issues with some of my MXDs where I have used a base map. These MXDs often will not open and I either have to reset my PC or run through the steps above to try and avoid the crash on opening.

  • I forgot to add.. MXD Dr also went to NOT RESPONDING only with these mxd's. I will try that in Catalog. – Zoran Jan 25 '18 at 11:00
  • I tried doing that with Catalog this morning, same issue.. "Not responding" only to those mxd's that came from the same guy who created them in . All other mxd's function like they should. – Zoran Jan 25 '18 at 13:28
  • So the originator of the MXD cannot open the MXD? Is it linked to any online sources or external databases? I saw this link this morning and thought maybe it would work for you too? I think ignore the question, but look at the answers given to the issue. They may offer ideas for your problems. gis.stackexchange.com/questions/84855/… – Keagan Allan Jan 25 '18 at 14:02
  • The originator can, but myself and one other person using his ArcGIS program can not either. I ran the ArcGIS defragmenter, that did not help. I tried the Catalog, right click for Data Source and was hoping I would be able to delete layers in there but I do not think that is possible. – Zoran Jan 25 '18 at 14:32
1

SOLUTION.. I ended up opening a blank mxd and clicked to the problem mxd. It opened 15-20-ish minutes later. All the layers were broken from all the data being moved to a new drive.

Thank you for all the help as I learned a few new problem-solving ways.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.