3

Novice warning... I have searched the answers for adding Map Servers to QGIS, but it appears that the link to my service ends with "ImageServer," rather than "MapServer." I cannot convince QGIS 2.18.12 to load any layers from the URL. This is the URL:

http://services.kansasgis.org/arcgis7/rest/services/IMAGERY_STATEWIDE/FSA_NAIP_2014_Color/ImageServer

When I attempt to add this through Layer>Add Layer>Add ArcGIS MapServer Layer, I get this lovely response:

enter image description here

Is there another Add Layer method that would work for this? I have tried all of the other web-based add layer formats with no luck.

2

Note this answer doesn't exactly add an Image Service in QGIS, but it does add the layer you are trying to add.

Browsing the ImageServer link you provided, I see a "WMS" link at the top of the page. Copy that link, and use it to create a new "WMS/WMTS" connection.

I'm running QGIS 3.2.0, so the naming might be different, but that process worked for me.

2

I am a beginner with QGIS too so it helps me to write things up. I already upvoted dangowans' answer but here are more specifics for QGIS 3.2, too. I am adding a service for a Bare Earth Hillshade for Oregon, see https://gis.dogami.oregon.gov/arcgis/rest/services/Public/BareEarthHS/ImageServer -- that is hosted on ArcGIS ImageServer. There is a set of links at the top of the page "JSON | SOAP | WMS". Right click on WMS and copy the link location. In QGIS under Layer -> Add Layer choose Add WMS Layer (or type Ctl-Shift-W); this should open a Data Source Manager dialog. Click "New" and paste the link into the "URL". Give the connection a meaningful name; I used "DOGAMI" for this one.

You can generally leave all the other options at their defaults but I chose a different projection for my project to better match my other data (OGIC).

Click OK. Back in the Data Source Manager, click Connect. If everything worked you should see a list of what services are available on this server.

Select a service by clicking on it, then click Add. It won't add the layer unless you click Add. (Close or double click won't do it.)

Here is the full WMS service URL, the one you paste in should be similar: https://gis.dogami.oregon.gov/arcgis/services/Public/BareEarthHS/ImageServer/WMSServer?request=GetCapabilities&service=WMS

Screenshot of dialog

1

If it is an tile image server (TMS) you can try adding it using the method outlined here:

https://www.lutraconsulting.co.uk/blog/2016/10/26/qgis-xyz-tile-wmts-preview/

0

That issue is fixed in the current version. Update the plugin.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Please check out our short tour to learn about our focussed Q&A format. – PolyGeo Sep 6 at 9:10
-1

Try this, it may or may not work for you: http://plugins.qgis.org/plugins/ImageServerConnector/

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • This plugin was very promising, but (in increasing order of disappointment) its dialogs are jarringly different from everything else in QGIS (v 3.6), the layer I produced with it required some extra refreshing to get it to draw appropriately, every map extent change brought the layer back to the top of the Layers list (which meant that it hides everything but labels), and caused a Python error that prevented me from saving my project. – id est laborum Aug 26 at 4:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.