I am using QGIS 2.18.15. I got some trouble to add an asc-file as a raster layer into QGIS. I tried to add the raster layer the normal way via the tool bar bottom. It did not work. (“The file source is not supported”)

Then I tried to convert the data via Raster: Conversion: Translate (convert format) menu option as it is suggested at StackExchange (Manipulate .asc files in qgis). It did no work ether. Here is the same problem “not recognized as a supported file format.”

enter image description here

The data I would like to add is from the following link. ftp://ftp-cdc.dwd.de/pub/CDC/grids_germany/multi_annual/solar/

It does not matter which data package I downloaded neither of them worked out.

  • They do work by using drag&drop from the browser. As alternative you can rename them to .xyz
    – Matte
    Commented Jan 26, 2018 at 10:32

1 Answer 1


Unzip files and then open them in your preferred text editor. Remove all header lines before NCOLS.

enter image description here

Then you can plot them on EPSG:31467 projection.

enter image description here

  • 2
    Make absolutely sure that you have word-wrap off, otherwise you will corrupt the raster. Commented Jan 26, 2018 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.