0

Apparently, the new released SNAP 6.0 allows the sen2cor plugin to be installed and run directly within the SNAP. Indeed, SNAP installs the bundle when try to run it.

However, it doesn't work for me. Although a new folder is generated (S2A_MSIL1A...from the S2A_MSIL1C), the folder does not contain the corrected bands.

Is there anyone that succeeded with it without using Anaconda nor the standalone sen2cor tool?

I enter the image through the MTD_MSIL1C file within the download folder S2A_MSIL1C_...

Then I run the sen2cor and a new folder is generated named S2A_MSIL2A_...

But inside the latter folder I just have two empty folders: AUX_DATA and DATASTRIP

Any suggestion?

enter image description here

  • S2A_MSIL1A or S2A_MSIL2A? Why aren't the correct bands on folder? – aldo_tapia Jan 26 '18 at 12:16
  • I enter the image through the MTD_MSIL1C file within the download folder S2A_MSIL1C_... Then I run the sen2cor and a new folder is generated named S2A_MSIL2A_... But inside the latter folder I just have two empty folders: AUX_DATA and DATASTRIP Any suggestion? – Nico_77 Jan 26 '18 at 12:34
  • Let me try with v. 6.0. The bands are in Granule folder – aldo_tapia Jan 26 '18 at 15:15
  • Ok thanks a lot. I will looking forward. Hopefully it could be solved. – Nico_77 Jan 26 '18 at 15:50
1

How did you install Sen2cor? Did you follow this procedure?

I installed SNAP v 6.0 and download Sen2cor 2.4 stand-alone installer follow the procedure mentioned in STEP forum. I've set environmental variables in SNAP too, it's the most important part to be successful:

enter image description here

enter image description here

I was careful, but setting could be:

  • SEN2COR_HOME = $USER_HOME
  • SEN2COR_BIN = $SEN2COR_HOME/bin or $SEN2COR_HOME\bin in Windows
  • SEN2COR_EXE = $SEN2COR_BIN/L2A_Process or $SEN2COR_BIN\L2A_Process in Windows
  • USERPROFILE = ~
  • HOME = /Users/your_user in OS X, or C:\Users\your_user\ in Windows
  • USER_HOME = $HOME

With this configuration, bands are created without problem:

enter image description here

  • Dear Aldo Thank you for your reply. Actually it seems kind of strange because following the procedure the sen2cor works on one computer but not on others PC. Well at any rate I can work on it on one PC at least. – Nico_77 May 4 '18 at 15:25
  • @Nico_77 Did you tried to run Sen2cor in command line? – aldo_tapia May 4 '18 at 15:51
  • Yes I tried but I not succeded – Nico_77 May 4 '18 at 15:54
  • Anyway I have read that next version of SNAP will fix the issue – Nico_77 May 4 '18 at 15:54
  • @Nico_77 by the information that you give me I think is not a SNAP issue, maybe you're trying to make it run in a 32bit computer – aldo_tapia May 4 '18 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.