I have a large map with an inset. In Arc9.3 I was able to copy that inset data frame into another mxd to use again as another inset - it is set up exactly how it is needed. Rather than re-build a new dataframe and add all the layers and symbolize, its way easier to re-use a dataframe already created. When I try to do this in Arc10.0, the dataframe copies okay however when I try and access the dataframe properties, it crashes ArcMap. (The only adjustment I need to do in the properties is to reset the map extent frame.) The steps I took to access properties, right click & choose properties. Upon chosing properties, ArcMap crashes. This process worked so smoothly and without error in previous versions. I feel frustrated with this simple task. Is there another way to re-use an existing dataframe, without ArcMap crashing?

Not every time, but sometimes this error pops up before the crash: enter image description here

  • 2
    Have you tried re-creating the empty dataframe and then copy/pasting all the layers?
    – blah238
    Jun 6, 2012 at 18:58
  • That's my next step... just a pain to do that several times, including the map annotation. grr. Jun 6, 2012 at 19:00
  • @blah238 - gave you props because it was the solution I used and I couldn't mark it as answered. Jul 10, 2012 at 16:16
  • SP5 is out now; that fix it? Alternately, you can copy the comment to an answer yourself and mark it accepted. You've already told @blah238 this was what worked and there has been ample time for him/her to convert to an answer. It's a gift :) (good form to add more detail and credit source of course) Aug 31, 2012 at 18:52
  • Whoops -- I added the workaround to my existing answer. Missed @Sue's last comment.
    – blah238
    Aug 31, 2012 at 19:18

2 Answers 2


This might be fixed in Service Pack 5.

NIM079457 - A map document that opens in Version 9.3.1 crashes when opened in Version 10.

As a workaround, try re-creating the empty dataframe and then copy/pasting all the layers.

  • hmmm that's nice. doesn't help me today. I look forward to the service pack. Jun 6, 2012 at 18:54
  • Oh, and this is all happening with v10.0. I'm not using a dataframe from 9.3 putting it in 10. I'm going from 10.0 to 10.0. Jun 6, 2012 at 19:02
  • But was the MXD originally authored in 9.x?
    – blah238
    Jun 6, 2012 at 20:32
  • No. Brand new in 10.0. Jun 6, 2012 at 20:43
  • I used the workaround. Have yet to install the SP. Sep 11, 2012 at 16:12
    Runtime error!
R6025 - pure virtual function call

Latest Service Pack recommended

Potential Reasons - Memory Error (check RAM)

Lack space on the data drive. (or Network Drive)

Polygons that at least have one place two of the vertices had identical coordinates (fix)

old but resourceful source: http://forums.esri.com/Thread.asp?c=93&f=982&t=55146

  • Interesting forum discussion. Seems like various issues result in a Runtime error. Perhaps ArcMap is confused, in my case, with the dataframe being used across two mxd's. Hopefully service pack 5 (July release) will solve this issue. For now, I rebuilt the inset for each map product. Took longer but necesarry. Jun 6, 2012 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.