I installed the 32-bit version of the latest QGIS (2.18.16) and get this error message when loading restored plugins:

C:PROGRA~1\QGIS2~1.18\apps\saga-ltr\saga_cmd.exe is not a valid Win32 application.

Where do I remove the reference to this executable?


I had the same problem and fixed it by:

  1. getting the win32 zip of SAGA-GIS v. 2.3.1 (not ltr, there is no reference of ltr there) from their sourceforge repository https://sourceforge.net/projects/saga-gis/files/SAGA%20-%202/SAGA%202.3.1/
  2. going to the \apps subfolder of the qgis installation folder (by default c:\Program Files\QGIS 2.18\apps) and renaming folder saga-ltr to something different, e.g. saga-ltrback
  3. unzipping the files from sourceforge there (as a subfolder of \apps) and renaming the created folder (in this case saga_2.3.1_win32) to saga-ltr.

This seems to work; there are no warning and I tried two geoalgorithms and they seemed to work as expected. I haven't done extended tests though.

Before that, I had tried:

  • to use osgeo4w setup (advanced mode) to download the saga-ltr package and replace as above--it was the same version (2.3.2) as the one that comes with qgis 2.18.16, and they were the exact same files and also didn't work

  • to use osgeo4w setup (advanced mode) to download the saga package and replace as above--it was version 2.1.2, it started as a standalone and qgis started without warnings, but there were no SAGA geoalgorithms in the qgis toolbox.

I hope this helps for the time being.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.