1

I have a series of raster files I´d like to clip to the same extent. To do so I am using a shapefile as mask through the method (raster >extraction> clipper) but every time I do so I keep getting the same error "cutline feature without geometry".

I have tried many suggestions in this site. Amongst the most common; I have validated my shapes geometry and it seems to have no errors, the files are in the same projection, and the polygon I am using as a mask to clip my raster files is smaller than the extent of these.

I know it´s a very common topic but I am running out of options and I am there might be a problem either with my raster files or my shapefile which I am obviously overlooking.

I leave the link to the zip files below.

Zip files

enter image description here

3

This looks like a problem with your polygon layer rather than the tool itself. Using the files you supplied, I encounter the same issue. There appears to be one feature, but multiple entries in the table. Running a number of different tools, the processing log often spits out Feature n has invalid geometry. Skipping...

I can't make sense of what's wrong with this layer.

Solution:

Rather than dig into the details of the layer itself, I just ran Fixed distance buffer with a Distance of 0. Using this new vector layer as your mask layer should work just fine.

Updated Solution:

I revisited this out of curiosity, and those empty features were the problem. As the features have no actual geometry to them, they're the reason you get the "...without a geometry" error message.

Selecting by expression $area IS NULL and then deleting left the table with one feature, the polygon we're masking with. The raster was then able to be clipped using the original shapefile.

output

  • Correct! The problem was with my polygon. I tried what you suggested and it ran swiftly, also tried creating my polygon from another raster file and it ran without problem. I still don´t understand what was the problem, but it is working now. Thanks a lot, it was great help! – dmct.92 Feb 2 '18 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.